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1: Introduction

The CV (control voltage) DAC (digital-to-analog converter) is an inexpensive do-
it-yourself option that allows for greater control of the Pro One from an external
MIDI device (keyboard, sequencer, etc.). While the installation is fairly simple
(much easier than the MIDI board for instance), it still requires some electronics
knowledge and soldering skills. Improper installation could damage your Pro
One. We accept no responsibility for the work you perform on your Pro One.
Read over the following installation description and if you feel you are not
capable of the work required, turn the project over to a qualified technician.

Note: The elements are all controlled by MIDI so MIDI circuitry is required for the
CV module to operate. This option requires TurboCPU firmware v1.10 or newer.

Precautions!

HIGH VOLTAGE! piscoNNECT ALL POWER BEFORE ssnwcmeéa

A WARNING] FAILURE TO DO SOMAY CAUSE PROPERTY DAMAGE, PERSONAL
INJURY OR DEATH.

High Voltage Safety Warning

Turn the Pro One power switch OFF and disconnect the AC power cable before
opening the Pro One.

ESD Precautions and Proper Handling Procedures

You should observe standard static-safe handling behavior when working with
sensitive electronic equipment such as synthesizers:

o Avoid carpets in cool, dry areas.

o Dissipate static electricity before handling any system components by
touching a grounded metal object.

o If possible, use anti-static devices, such as wrist straps and floor mats.

o Take care when connecting or disconnecting cables. A damaged cable
can cause a short in the electrical circuit. Note the polarity and position for
later re-installation.

o Prevent damage to the connectors by aligning connector pins before you
connect the cable. Misaligned connector pins can cause damage to
system components at power-on.

o When disconnecting a cable, always pull on the cable connector or strain-
relief loop, not on the cable itself.

Please follow the Pro One disassembly instructions in the MTG TurboCPU
installation manual.
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2: Installation

Tools and Parts Required for CV

o This manual assumes that a MIDI/Jack Board Rev C or later is already
installed in the Pro One.*

0 You will need a Microchip MCP4728 DAC chip and a daughterboard for it
that converts the MSOP10 pinout to a regular 0.3" 10-pin DIP layout.
These are readily available and inexpensive.

o Screwdrivers, soldering iron, solder and hook-up wire.

DAC Chip Installation (if required)

Installation of the DAC chip is not difficult but it does require fine soldering and
magnification (magnifying glass, loupe, etc.). There are many useful videos on
YouTube demonstrating surface mount device soldering.

The Pro One MIDI board is designed to take a 10-pin DIP device. The [ ..
DAC chip is a very tiny MSOP-10 package. You can buy the chip and §ies
adapter board separately or assembled. It is also available as an | ==
installed option from MTG for extra charge.

Here are some examples of bare adapter boards (also called breakout boards):

http://www.nkcelectronics.com/msop10-to-dip-adapter-101010.html

http://www.ebay.com/itm/3-Pcs-SMD-CONVERTER-ADAPTER-PCB-MSOP8-MSOP10-0-5-mm-
/120750047844

Finally, you can purchase a complete daughterboard here:

L If you are using an older version of the Pro One MIDI board, or have constructed your own MIDI
interface circuit, contact MTG for instructions on adding do-it-yourself CV circuitry.

MTG Pro One TurboCPU Page 4 of 17 CV Install



http://www.proto-
advantage.com/store/p/MCP4728 Breakout Board.php?gclid=CKyByJrNk78CFZJbfgodBA4AkQ

If you are soldering the DAC yourself, the most important points are to observe
pin 1 orientation and to clean up any accidental solder bridges with (static free)
SolderWick.

Once you have a properly soldered daughterboard, it is a simple procedure to
install it on the MIDI board. You can use toothpicks to elevate the daughterboard
off of the MIDI board during soldering. Or use a socket trimmed to 10 pins.
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Wiring Block Diagram
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Recommended Hookup Diagram

DAC Wiring Summary

Make sure the MIDI interface is functional before you begin the DAC hook-up.
Later you may need to update the firmware to include support for the CV
functionality. Power connections +5v and Gnd are shown for completeness.

You will need to solder wires on the TurboCPU, the MIDI jack board and the Pro
One main board. If you have not done so already, disassemble the Pro One as
described in the TurboCPU Installation Guide.

1.

2.

Hook up SCL and SDA signals from the Turbo CPU to the v2 MIDI board.

Connect two wires from VOUT_A to the CV summing points for OSC A
and OSC B.

Connect a wire from VOUT_B to the CV summing point for the Filter
Cutoff.

Connect a wire from VOUT_C to the Filter Resonance chip.
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When you connected the MIDI wiring, you connected +5v, ground, MIDI Rx and
MIDI Tx. All that remains on the CPU connection side are the two DAC 12C
control lines SCL and SDA (see the diagram above).

On the Turbo CPU module locate the two points for attaching to SDA and
SCL. Solder two wires onto the Turbo CPU module and connect them
directly to the corresponding pins on the v2 MIDI Jack Board at header J2.

CV1: VOUTA to OSC A

Using only a wire connect J3 pin 1 (CV1 or VOUT,) to OSC A on the Pro
One. The 100k 1% metal film resistor shown is already installed on the MIDI jack
PCB.
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CV1: VOUT,to OSC B

Using another wire connect J3 pin 2 (CV1 or VOUT,) to OSC B on the Pro
One. The 100k 1% metal film resistor shown is already installed on the MIDI jack

PCB. Yes, it's the same CV, but a different wire from a different resistor!
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Step 3. CV2: VOUT; to Filter Cutoff

Using another wire, connect CV2 (VOUT B) to the Filter Cutoff summing point.
The 47k resistor shown is already installed on the MIDI jack PCB.
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Step 4. CV3: VOUT. to Filter Resonance

Using another wire, connect CV3 (VOUT C) to the Filter Resonance pin. The 47k
resistor shown is already installed on the MIDI jack PCB.
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3: Using the CV/DAC Option

Once the wiring is complete, reassemble the Pro One.

The operating information for the CV/DAC option is located in Chapter 3 of the
TurboCPU User Guide.

Additional MIDI information is located in the appendix of that document as well.
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Appendix A: Firmware Upgrade using the PC App

DO ONLY IF NEEDED. The CV functionality requires firmware v1.11 or later.
Obtain the latest firmware in .SYX format from the MusicTechnologiesGroup.com
website. This section assumes you have installed the TurboCPU.exe Windows
application. More information about the application is available in the User Guide.

You may lose your sequencer data and user parameters as a result of a firmware
upgrade. The Windows™ PC application will allow you to back this data up to
your PC if you wish.

With your Pro One attached to your MIDI interface and turned on, launch the
Windows PC program. From the MIDI (select/open) menu choose the correct
MIDI IN device and the correct MIDI OUT device. If the software can
communicate with the TurboCPU you may proceed.

Select the Firmware tab in the application.

MIDI  Help

Main Settings Seguencer CV/DAC -Beta Firmware

Firmware Upgrade File

B Launch Bootloader via MIDI*

Factory Reset via MIDI**
Instructions: - !

1. Open your firmware upgrade .5YX file from disc using the "Load from Disc™ button.

2. Place the Pro One keyboard into Bootloader mode: Power-on while holding top two keys down. (Or try button above v1.30+ only™).
3. Choose your MIDI Interface from the Manu.

4, Click on the "Write to Pro One” button and wait until the update completes.

5. Itis recommended to perform a “3-key factory reset” after firmware update. (Or try above button v1.32+ only ™)

Filename:

[ Load from Disc Write to Pro One
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If your Pro One is not in Bootloader mode, then you need to do that now. If your
TurboCPU is v1.30 or newer you can click the provided Launch Bootloader via
MIDI button. Otherwise launch the bootloader using manual power-on method.

To launch the bootloader manually, start with the Pro One turned
off. Hold the two highest notes down (B2 and C3, keys 36 and 37).
While holding them down, power on the Pro One. The bootloader
will emit several short notes. After that the bootloader remains in
control of the synth.

Use the Load from Disc button to locate the .SYX firmware file by browsing your
PC for the file you downloaded. Once the file is loaded, the upgrade
automatically starts. Do not disturb the process until it is complete (about 30
seconds).

After a few moments the firmware update will finish. It is recommended that you
perform a Factory Reset at this time to load the default settings. You should be
able to use the Factory Reset via MIDI button if your new firmware version is
v1.32 or newer. Reload your settings and/or sequence data if you like.
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Appendix B: Firmware Upgrade using MIDIOX

DO ONLY IF NEEDED. The CV functionality requires firmware v1.11 or later.
Obtain the latest firmware in .SYX format from the MusicTechnologiesGroup.com
website. We show the process using MIDIOX, but you should be able to use any

similar program.

You may lose your sequencer data and user parameters as a result of a firmware

upgrade.

Configure MIDIOX

Set the Sys Ex properties of MIDIOX by clicking:

View->SysEX...

and then SysEx->Configure

Use the minimum recommended setting shown here:

Command Yindow

| Display Windaw

M SysEx View and Scratchpad

¥ FrE e [T e
and Window isnlasy Window

Configure

Lo Lewvel Input Buffers

200C
16

ok,

g

Size Butes

II K

Cancel
Murm

.

Lo Level Output Buffers Drelay
Size (200013 Bytes 200 |8
Mum |16 & MilliS econds

Between Buffers

Delay After E7: |200 ¢| Mili5 econds

[] Dor't ' arn to Save Changes

[ ]&ppend To Bytes in Display Window
Fill Dizplay Window az Butes Come In
Show FOFT in colored text

[ 15ave Dump directly to a file

eceived
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Prepare the Pro One for Download

Hook up the MIDI connections to your computer and to the Pro One. Launch the
Pro One in bootloader mode by turning off the Pro One, holding the two highest
keys (B2 and C3) and then while holding those keys down, turning the Pro One
on. You should hear several short notes that indicate the MIDI bootloader
program is in control.

Test the Communication

If you send a Universal Device Inquiry system exclusive packet to the Pro One, it
will respond with the MidiLoader version packet. In MIDIOX, click:

View->SysEX...

Then from the SysEx menu click
Command Window->Load File...

Choose the file Universal Device Inquiry.syx and click open. Click
Command Window->Send/Receive Sysex

The Pro One bootloader will respond with 24 bytes. Click on Done. Next click on
Display Window->Hex View Swap

You may have to enlarge the window a little, but you should see something like:

I SysEx Yiew and Scratchpad E||E|Pz|
File Command Window Display Window  Swsex  Help

Command “Window  Plain Hex C:WProgram Filesh. . A\Univerzal Device lnguing.syx, B Butes
FOO 7E YF 06 01 F7Y

Display Windaw Formatted Hex 24 Buytes Received
000DD0  FO 7E 7F 06 02 7D 21 4D 69 64 69 4C 6F 61 64 65 .~...} 'MidiLoade
oooo1o 7z 2o 76 31 2E 30 30 F7 ] r v1.00.
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The message must say MidiLoader not ProOne CPU! If it does, you have not
launched the bootloader properly. Repeat the above steps carefully. Once you
verify the MidiLoader message you can proceed with the firmware upgrade.

Firmware Upgrade

Close the SysEx View window and open it again to get an empty window. If you
are prompted to save anything, click No. Open the new firmware file by clicking

Command Window->Load File...

Choose the file required for the upgrade (E.g. ProOne_v2_00.syx). You should
see that a fairly large file is opened. Click on

Command Window->Send/Receive Sysex

The upgrade takes approximately 30 seconds. Do not touch the computer or Pro
One during this time. At the end of the upgrade the Pro One will reboot. Also the
MIDIOX screen will show a fairly large number of transactions. You can close
MIDIOX (don’t save anything) and begin using the updated Pro One.

If the Pro One doesn’t reboot, verify that the Pro One is operational. If not, repeat
the download.

You are advised to perform an MTG Factory Defaults procedure on a newly
reflashed CPU. This will wipe your settings, but it prevents the CPU from
operating in an unstable state.

MTG Pro One TurboCPU Page 17 of 17 CV Install



	CONTENTS
	1: Introduction
	Precautions!

	2: Installation
	Tools and Parts Required for CV
	DAC Chip Installation (if required)
	Wiring Block Diagram
	DAC Wiring Summary
	Step 1. CPU-to-CV Hookup
	Step 2. OSC A and OSC B
	Step 3. CV2: VOUTB to Filter Cutoff
	Step 4. CV3: VOUTC to Filter Resonance

	3: Using the CV/DAC Option
	Appendix A: Firmware Upgrade using the PC App
	Appendix B: Firmware Upgrade using MIDIOX

