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1: Introduction 
 
 
Precautions! 
 
 

 
 
 
High Voltage Safety Warning 
 
Turn the Pro One power switch OFF and disconnect the AC power cable before 
opening the Pro One.     
 
 
ESD Precautions and Proper Handling Procedures 
 
You should observe standard static-safe handling behavior when working with 
sensitive electronic equipment such as synthesizers: 
 

o Avoid carpets in cool, dry areas. Leave the CPU module in its anti-static 
packaging until it is ready to be installed. 

o Dissipate static electricity before handling any system components by 
touching a grounded metal object. 

o If possible, use anti-static devices, such as wrist straps and floor mats. 
o Always hold the CPU module by its edges. Avoid touching the contacts. 
o Take care when connecting or disconnecting cables. A damaged cable 

can cause a short in the electrical circuit. Note the polarity and position for 
later re-installation. 

o Prevent damage to the connectors by aligning connector pins before you 
connect the cable. Misaligned connector pins can cause damage to 
system components at power-on. 

o When disconnecting a cable, always pull on the cable connector or strain-
relief loop, not on the cable itself. 

 
 
Tools Required (CPU only) 
 

o Standard flat-head screwdriver. 
o Plastic ruler or straight edge for checking the module height in the socket. 
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Additional Tools Required for MIDI 
 

o Philips screw driver and small plyers. 
o Soldering iron, solder. 
o Tools necessary for mounting the MIDI and printed circuit board. 

 
 
 
Additional Tools Required for D-I-Y CV 
 

o MCP4728EV quad DAC board. 
o Pull-up resistors (2) and interface resistors (4). 
o Soldering iron, solder and hook-up wire. 
o Double-sided foamy tape or some other method of securing the PCB. 

 
 
 
Condition of Pro One 
 
While the Pro One Turbo CPU will replace the functionality of a damaged or 
missing CPU, it will not correct other problems your vintage synthesizer may 
have. It is recommended that the synth be in otherwise good condition before 
beginning the installation. For instance, the keyboard bushings will need to be 
replaced on units that have never had them replaced before (they dry out over 
time and become very brittle). Keyboard contacts should be attended to as 
required according to the procedure in the Pro One owner’s manual.  Finally, the 
two sockets at the end of the keyboard flat cable are of poor quality and are also 
prone to oxidation over time. This makes the key contacts more critical. Consider 
having the sockets replaced. 
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2: Installation 
 
Preparation 
 
Carefully remove all of the knobs on the front panel of the Pro One.  You should 
also locate a small container to place the screws in while you work on the synth. 
 
Open the Pro One 
 
Continue with the following steps, taken from the Pro One Operation Manual: 
 

1. Switch the power off and unplug the power cord. 
2. Remove the wooden side panels (2 screws each side). 
3. Remove three screws along the front edge. 
4. Carefully slide the top panel assembly forward. When the front edge is 

clear of the keys, lift it up just enough to allow clearance for your hand. 
5. Note the position and polarity of the AC power connector. Mark the 

connector or take a photograph of it so that you can refer to it later. 
6. Disconnect the AC power connector running from back panel to the 

underside of the printed circuit board (PCB), at right. 
7. Note the position and polarity of the keyboard cable where it attaches to 

the PCB. Either mark the connector or take a photograph of it that you can 
refer to during reassembly. Disconnect the keyboard cable from the PCB. 

8. Do the same for the bender wheel/mod wheel cable. 
 
Remove the Panel PCB 
 
The number of screws used to attach the front panel PCB to the front panel 
varies by production year.  Remove all screws carefully and take care not to 
stress the front panel PCB.   
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Set the panel PCB down on a static safe surface that provides uniform support 
for the PCB.  Do not allow the PCB to flex unnecessarily. 
 
 
 
MIDI Board Installation (Optional) 
 
Please read through this section at least once and PLAN your wiring before 
beginning.  The schematic of the MTG Pro One MIDI board is shown below.  
The LEDs and MIDI Thru connector are not required. 
 

 
This is one of many circuits that would do the job of converting the CPU’s 3v TTL 
signals into the standard MIDI current loop.   
 
See also: http://www.midi.org/techspecs/electrispec.php 
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Mount the MIDI Connectors 
 
Although the MIDI board supports PCB mount 5-pin DIN connectors, most 
people prefer the chassis mount connectors: 
 

  
Chassis mount PCB mount 

 
 
 
Remove the 37-key keybed assembly if 
required.   
 
To mount the connectors in the metal 
chassis you will need to drill/punch holes 
for the connectors. Use the guide on the 
right for making the holes.  A Greenlee 
punch can be used to make nice holes with 
a minimum of fuss. Recommended! 
 

16.5 mm is approx 5/8” 
3.2mm is approx 4/32” 

 
Make sure any metal residue is removed 
before reinstalling any electronics. 
 
 
 
 
Mount the PCB 
 
The PCB has 4 holes that can be used to fasten it to the chassis bottom or panel 
side. Ideally you should mount the PCB as far away from the sound generation 
electronics as feasible. In lieu of nuts and bolts you may use double-sided foamy 
tape or Velcro for installations that will not be subject to road trips. 
 
Once the PCB and MIDI jacks are mounted, it is a simple matter to connect a few 
wires to the CPU module and jacks. 
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Jack Wiring 
 
If you are using chassis mount connectors then you will need to run connections 
from the PCB to the panel jacks.   Use the diagram below to hook-up the wires. 
The optional MIDI Thru is connected in the same manner as MIDI Out. 

1

2

3

4
51

2

3

4
5

MIDI IN
MIDI OUT
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CPU Module Wiring 
 
Determine a path for the wiring from the jack PCB to the CPU module. If you run 
your wiring on top of the Pro One main board, then follow the signal path 
Sequential used for the expansion port.  This keeps the MIDI signals away from 
the audio path. Alternatively run the wiring off the main PCB near the CPU 
module. 
 

 
 
 
Using hookup wire, connect the 
four pins one-to-one between 
the CPU module and the jack 
board. Use the following two 
diagrams as a guide. 
 
The wiring should run under 
the MTG CPU board, not on top 
of it. There is very little vertical 
space above the CPU board for 
anything (about a tenth of an 
inch).  Therefore, when 
connecting the wires from the 
CPU board to the MIDI jack 
board, run the wires beneath the CPU board, to the bottom pads on the CPU 

+5v
Ground

MIDI IN
MIDI OUT
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board and solder on top. Trim the wires neatly on top so that they do not short 
against the front panel when closed. 
 
 

 
 
 
Another Wiring Option 
 
A third wiring option is to run the 
cabling outside of the Pro One to 
an external box or board.  If you 
notice the top edge of the rear 
panel, there is a small gap near 
the modulation section. This was 
originally intended to route 
external cabling for the DIP 
“expansion” socket.  It can easily 
be used to run a flat cable 
outside the Pro One to an 
external box. 
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CPU Module Installation 
 
 
Inspect the area around the existing 8021 CPU (or socket).  To the left and right 
of the CPU are switches. Just “above” it is the Digital-to-Analog converter (DAC) 
chip facing sideways.  The DAC is located at the Pin 1 end of the CPU socket.  
Make sure you know which pin on the CPU socket is Pin 1.  The new module will 
use up almost the entire area bordered by the DAC and the two switches. 
 

 
 
When installed, the module electronics must not sit higher than the height of the 
metal on the switches because the metal front panel resets approximately on the 
switches.  A small rubber pad has been placed on the new CPU module to keep 
it secure and insulate it from the front panel. 
 
If the original 8021 CPU is present, remove it using a small flat head screwdriver. 
Take care not to bend the leads. Place the 8021 on anti-static foam in case you 
ever want to re-install it or sell it. If the CPU is defective, throw it away.  Really. 
 
Take the Turbo CPU Module out of its anti-static packing and locate pin 1 on the 
module.  Pin 1 is located at the top left end of the board where the white 
silkscreen notch is printed. For verification, this end has a single 4-pin header. At 
the other end, near pins 14 and 15, there are two 4-pin headers. 
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Carefully align the 28 pins of the module directly above the vacant CPU socket.  
 
 

 
 
 

Press the module firmly and evenly into place as low as it will go. The two yellow 
resistor packs on each underside should either touch the panel PCB or be very 
near to it.  
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Verify that there are no electrical parts on the CPU module that extend above the 
line where the front panel will rest (on top of the switches). 
 

 
 
 
Carefully reassemble the unit in reverse order.  
 
Make sure the new CPU module fits cleanly in the pre-existing notch that 
Sequential has provided in the plastic front panel.  In the unlikely event that the 
plastic front panel hits the CPU module, you may need to loosen all of the front 
panel hex nuts and adjust the position of the plastic panel versus the metal front 
panel.  
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Test 
 
 
After carefully reassembling the unit, plug the Pro One power in and connect an 
amplifier. Turn the Pro One on. Verify that the module has been installed properly 
and is functioning.  Any problems are likely to be as a result of improper pin 
alignment when installing the module in the CPU socket.  
 
 
Sometimes the original CPU socket is in 
poor condition and a new dual-wiping 
socket is recommended. Make sure that 
any replacement socket is low profile.  
 
 
 
 
Bootloader Launch 
 
 
If you have installed the MIDI hardware you can utilize the built-in MIDI 
bootloader to upgrade the firmware.  To launch the bootloader, start with the Pro 
One turned off. Hold the two highest notes down (B2 and C3, keys 36 and 37). 
While holding them down, power on the Pro One.  The bootloader will emit 
several short notes. After that the bootloader remains in control of the synth. 
Follow the instructions in Appendix A.  
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3: CV Module Installation (Preliminary) 
 
The CV Quad DAC board is an inexpensive do-it-yourself option that allows for 
greater control of the Pro One from an external MIDI device (keyboard, 
sequencer, etc.).  While the installation is fairly simple (much easier than the 
MIDI board for instance), it still requires some electronics knowledge and 
soldering skills. Improper installation could damage your Pro One. We accept no 
responsibility for the work you perform on your Pro One.  Read over the following 
installation description and if you feel you are not capable of the work required, 
turn the project over to a qualified technician.  
 
Note: The elements are all controlled by MIDI so the MIDI circuitry is required for 
the CV module to operate. The CV Module requires firmware v1.10 or newer. 
 
 
Parts List 
 
Here are the items you will need (the resistors are all through-hole): 
 

o (1) MCP4728EV - Microchip MCP4728 Evaluation Board or equivalent. 
o (2) 4.7k ohm ¼ watt resistors (for I2C pull-ups). 
o (2) 100k ohm 1% ¼ watt resistors (for OSCA/OSCB control voltage). 
o (1) 47k ohm ¼ watt resistor (for Filter Cutoff control voltage). 
o (1) 47k ohm ¼ watt resistor (for Filter Resonance control voltage). 
o Double-sided foam tape or Velcro to fasten the PCB. 
o Hook-up wire. 

 

From CPU

OSC A

MCP4728EV
Recommended Hookup Diagram

VSS

VDD

+5v

SCL

SDA

Gnd

4k7

4k7

DAC 1

100k 1%

100k 1%
OSC B

VOUT A

DAC 2
47k

CutoffVOUT B

DAC 3
47k

ResonanceVOUT C

DAC 4 no connectionVOUT D
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Tasks 
 
Here are the required major tasks for the left side of the diagram above: 
 

1. Hook up the +5v, Ground, SCL and SDA signals from the Turbo CPU to 
the MCP4728 board.   

2. Add the two 4.7k pull-up resistors in parallel with the existing ones on the 
MCP4728 board. These resistors in parallel with the existing ones on the 
MCP4728 will allow the Turbo CPU to drive the I2C lines much faster. 

 
Here are the recommended major tasks for the right side of the diagram above: 
 

3. Connect the two 100k 1% resistors from VOUT_A to the CV summing 
points for OSCA and OSCB. 

4. Connect the 47k resistor from VOUT_B to the CV summing point for the 
Filter Cutoff. 

5. Connect the 47k resistor from VOUT_C to the Filter Resonance chip. 
 
 
CPU-to-CV Hookup 
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It is necessary to run 4 wires from the Turbo CPU board to CV module. Please 
refer to the diagram above. 
 
Power 
 
On the Turbo CPU module locate two points for attaching to +5v (VDD) and 
Ground (VSS).  On the diagram above the +5v signal is marked in red and ground 
is marked in yellow. Solder the wires onto the Turbo CPU module and connect 
them to the corresponding pins on the MCP4728 board. 
 

 
Jumpers  
 
There are two jumpers on the MCP4728 board. The two jumpers (JP1=VDD and 
JP2=LDAC) are required, but you may prefer to solder wires on them instead of 
using the provided jumpers.    
 
I2C 
 
On the Turbo CPU module locate the two points for attaching to SDA and SCL.  
Solder the two wires onto the Turbo CPU module and connect them directly to 
the corresponding pins on the MCP4728 board. 
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Pull-ups 
 
In order to increase the speed of the I2C signals (SDA and SCL) it is necessary 
to add two 4.7k resistors in parallel with the two surface mount resistors already 
on the MCP4728 board.  Refer to the block diagram at the beginning of this 
chapter.  In each case, solder one resistor between the I2C line (SDA or SCL) 
and VDD. JP1 is a convenient location for attaching them to VDD. 
 
 
 
CV-to-Synth Hookup 
 
 

 
 
 
The following information describes how to connect the analog voltages from the 
MCP4728 board to the Pro One synth engine. 
 
 
CV1: VOUTA to OSC A 
 
Using a 100k 1% metal film resistor, connect CV1 (VOUT A) to OSCA. Each 
oscillator requires its own series resistor! Refer to the block diagram at the 
beginning of this chapter. 
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CV1: VOUTA to OSC B 
 
Using a 100k 1% metal film resistor, also connect CV1 (VOUT A) to OSCB. Each 
oscillator requires its own series resistor! Refer to the block diagram at the 
beginning of this chapter. 
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CV2: VOUTB to Filter Cutoff 
 
Using a 47k resistor, connect CV2 (VOUT B) to the Filter Cutoff summing point. 
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CV3: VOUTC to Filter Resonance 
 
Using a 47k resistor, connect CV3 (VOUT C) to the Filter Resonance pin. 
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Appendix A: Firmware Upgrade 
 
If you have installed a MIDI interface circuit, you can “reflash” the firmware in the 
Pro One CPU by carefully following the procedure outlined in this section. Obtain 
the latest firmware in .SYX format from the MusicTechnologiesGroup.com 
website. We show the process using MIDIOX, but you should be able to use any 
similar program. 
 
You may lose your sequencer data and user parameters as a result of a firmware 
upgrade.  
 
 
Configure MIDIOX 
 
Set the Sys Ex properties of MIDIOX by clicking: 
 

View->SysEx…   and then   SysEx->Configure  
 

Use the minimum recommended setting shown here: 
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Prepare the Pro One for Download 
 
Hook up the MIDI connections to your computer and to the Pro One. Launch the 
Pro One in bootloader mode by turning off the Pro One, holding the two highest 
keys (B2 and C3) and then while holding those keys down, turning the Pro One 
on.  You should hear several short notes that indicate the MIDI bootloader 
program is in control. 
 
 
Test the Communication 
 
If you send a Universal Device Inquiry system exclusive packet to the Pro One, it 
will respond with the MidiLoader version packet. In MIDIOX, click: 
 

View->SysEx… 
 
Then from the SysEx menu click 
 

Command Window->Load File… 
 
Choose the file Universal Device Inquiry.syx and click open. Click  
 

Command Window->Send/Receive Sysex 
 
The Pro One bootloader will respond with 24 bytes. Click on Done. Next click on 
 

Display Window->Hex View Swap 
 
You may have to enlarge the window a little, but you should see something like: 
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The message must say MidiLoader not ProOne CPU!  If it does, you have not 
launched the bootloader properly. Repeat the above steps carefully. Once you 
verify the MidiLoader message you can proceed with the firmware upgrade. 
 
 
 
 
Firmware Upgrade 
 
Close the SysEx View window and open it again to get an empty window. If you 
are prompted to save anything, click No.  Open the new firmware file by clicking 
 

Command Window->Load File… 
 
Choose the file required for the upgrade (E.g. ProOne_v1_00.syx). You should 
see that a fairly large file is opened. Click on 
 

Command Window->Send/Receive Sysex 
 
The upgrade takes approximately 30 seconds. Do not touch the computer or Pro 
One during this time. At the end of the upgrade the Pro One will reboot. Also the 
MIDIOX screen will show a fairly large number of transactions. You can close 
MIDIOX (don’t save anything) and begin using the updated Pro One. 
 
If the Pro One doesn’t reboot, verify that the Pro One is operational. If not, repeat 
the download. You are advised to perform an MTG Factory Defaults procedure 
on a newly reflashed CPU. 
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